Tuesday, November 27, 2007

Ubuntu problems

I was down with cold and throat infection all weekend and yesterday. And while I was in bed on saturday, I thought I should fix up the ubuntu installation on my machine. I have two other OS installations, RHEL 4.4 for work, Windows XP for all the PC only software (iTunes, Picassa uploader, Flickr uploader etc). I did install Ubuntu 7.04 on a 8GB partition on my HP 6400 laptop. I did install well, but the wifi just wouldn't work. I tried a bunch of things including ndiswrapper and followed numerous howtos on the net and still couldn't get it to work.

For me, Ubuntu was going to be primarily a home use OS and since I have wifi installed at home, and running wires is a strict no-no from my wife, using a OS where wifi doesn't work is useless for me. For that matter, even RHEL 4.4 doesn't support wifi, but thats where my teams develops and hence couldn't avoid. Instead, I avoid using RHEL at home!!

So, on Saturday, I got a install DVD of Ubuntu 7.10 and tried installing it. Shockingly, I could not even get it to install. The problem seems to be with the kernel module - linux-generic. After try a couple of times, (and screwing up my GRUB bootloader), I switched to trying and installing the kernel module - linux-server instead. Somehow that install did get done, but I still could not get XServer working, forget wifi. I eventually did lose hope. Decided to leave the installation is as is, reconfigured GRUB loader and made RHEL 4.4 as the default boot OS.

For those who have heard me harp about Ubuntu being the first "Linux for human beings" blah blah comments, this should come as a surprise, but alas, Ubuntu has again made me work with all these dirty hacks to get it going. I loved the idea of Ubuntu working off the box, but if it doesn't, then I am not the one to try hacks after hacks, recompilation after recompilation to make it work. This week, I am gonna try Fedora 7 or 8 and see if that works. If anybody had similar or contrasting experience, drop a comment or email.

Administrative note

All tech posts have now moved to http://tech.shreeni.info or you may subscribe to its RSS feed. In due course, I shall be moving it out completely, so if you follow my tech posts, please shift to following that blog.